首页 > 代码库 > HDU 2317 Nasty Hacks

HDU 2317 Nasty Hacks

Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2299    Accepted Submission(s): 1816


Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

 

Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.
 

Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
 

Sample Input
3 0 100 70 100 130 30 -100 -70 40
 

Sample Output
advertise does not matter do not advertise
 

Source
Nordic 2006





解题思路:继续水题。直接比较每行的三个数,如果第一个数大于第二个数减去第三个数,则需要做广告;若等于,就无所谓;否则,不做广告。





AC代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main(){
//	freopen("in.txt", "r", stdin);
	int n, a, b, c;
	while(scanf("%d", &n)==1){
		for(int i=0; i<n; i++){
			scanf("%d%d%d", &a, &b, &c);
			if(a < b - c) printf("advertise\n");
			else if(a == b - c)  printf("does not matter\n");
			else  printf("do not advertise\n");
		}
	}
	return 0;
}



HDU 2317 Nasty Hacks