首页 > 代码库 > HDU 1520Anniversary party 树形DP入门

HDU 1520Anniversary party 树形DP入门

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5333    Accepted Submission(s): 2459


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests‘ ratings.
 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
5


题意:公司party,n个人的活跃值给出来,然后告诉职位等级关系,并且职员和直接上司不能同时参加,求最多可以有多少人参加

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#define N 6009

using namespace std;

int n;
vector<int>v[N];
int dp[N][2];//布尔型数组
int fa[N];
int f[N];

void dfs(int node)
{
    int len=v[node].size();
    dp[node][1]=f[node];

    for(int i=0;i<len;i++)
    dfs(v[node][i]);

    for(int i=0;i<len;i++)
    {
        dp[node][1]+=dp[v[node][i]][0];//上司出席则职员一定不出席
        dp[node][0]+=max(dp[v[node][i]][0],dp[v[node][i]][1]);//上司不出席则职员可能出席也可能不出席
    }


}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&f[i]);
            v[i].clear();
            dp[i][0]=dp[i][1]=0;
            fa[i]=-1;
        }

        int a,b;
        while(~scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0) break;
            fa[a]=b;
            v[b].push_back(a);
        }

        a=1;
        while(fa[a]!=-1) a=fa[a];

        dfs(a);
        printf("%d\n",max(dp[a][0],dp[a][1]));
    }
    return 0;
}













HDU 1520Anniversary party 树形DP入门