首页 > 代码库 > 郁闷的C小加(二)

郁闷的C小加(二)

郁闷的C小加(二)

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述

聪明的你帮助C小加解决了中缀表达式到后缀表达式的转换(详情请参考“郁闷的C小加(一)”),C小加很高兴。但C小加是个爱思考的人,他又想通过这种方法计算一个表达式的值。即先把表达式转换为后缀表达式,再求值。这时又要考虑操作数是小数和多位数的情况。

输入
第一行输入一个整数T,共有T组测试数据(T<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个运算式,每个运算式都是以“=”结束。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数并且小于1000000。
数据保证除数不会为0。
输出
对于每组测试数据输出结果包括两行,先输出转换后的后缀表达式,再输出计算结果,结果保留两位小数。两组测试数据之间用一个空行隔开。
样例输入
21+2=(19+21)*3-4/5=
样例输出
12+=3.001921+3*45/-=119.20





代码:

 
#include<stdio.h>
double fun(double a ,double b, char ch)
{
if(ch==‘+‘)
return b+a;
if(ch==‘-‘)
return b-a;
if(ch==‘*‘)
return b*a;
if(ch==‘/‘)
return  b/a;
}
int main(void)
{
int i,n,top1,top2;
double x,t,a,b,num[1000];
char str[1000],ch[1000];
scanf("%d",&n);
while(n--)
{
top1=-1;
top2=-1;
scanf("%s",str);
for(i=0;str[i]!=‘\0‘;i++)
{
x=0;
if(str[i]>=‘0‘&&str[i]<=‘9‘)
{
while(str[i]>=‘0‘&&str[i]<=‘9‘)
{
printf("%c",str[i]);
x=x*10+str[i]-‘0‘;
i++;
}
if(str[i]==‘.‘)
{
printf("%c",str[i]);
i++;
t=0.1;
while(str[i]>=‘0‘&&str[i]<=‘9‘)
{
printf("%c",str[i]);
x=x+(str[i]-‘0‘)*t;
t=t*0.1;
i++;
}
}
num[++top1]=x;
}
if(str[i]==‘\0‘)
break;
if(str[i]==‘(‘)
{
ch[++top2]=str[i];
}
else if(str[i]==‘)‘)
{
while(top2>=0&&ch[top2]!=‘(‘)
{
printf("%c",ch[top2]);
a=num[top1];
top1--;
b=num[top1];
num[top1]=fun(a,b,ch[top2]);
top2--;
}
top2--;
}
else if(str[i]==‘*‘||str[i]==‘/‘)
{
while(ch[top2]==‘*‘||ch[top2]==‘/‘)
{
printf("%c",ch[top2]);
a=num[top1];
top1--;
b=num[top1];
num[top1]=fun(a,b,ch[top2]);
top2--;
}
ch[++top2]=str[i];
}
else 
{
while(top2>=0&&ch[top2]!=‘(‘)
{
printf("%c",ch[top2]);
a=num[top1];
top1--;
b=num[top1];
num[top1]=fun(a,b,ch[top2]);
top2--;
}
ch[++top2]=str[i];
}
}
while(top2>=0)
{
printf("%c", ch[top2]);
a=num[top1];
top1--;
b=num[top1];
num[top1]=fun(a,b,ch[top2]);
top2--;
}
printf("\n%.2f\n",num[0]);
}
return 0;
}


















        

郁闷的C小加(二)