首页 > 代码库 > poj 3264 Balanced Lineup ST算法

poj 3264 Balanced Lineup ST算法

点击打开链接 

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 36215 Accepted: 16954
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

给出奶牛的高度 问一段区间内最大的高度差

RMQ问题  第一发ST算法。。代码好挫

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 55555
using namespace std;
int prelog2[MAXN],stmax[MAXN][35],stmin[MAXN][35];
int n,a[MAXN];
void init(){
	prelog2[1]=0;
	for(int i=2;i<=n;i++){
		prelog2[i]=prelog2[i-1];
		if((1<<prelog2[i]+1)==i){
			prelog2[i]++;
		}
	}
	for(int i=n;i>=1;i--){
		stmax[i][0]=stmin[i][0]=a[i];
		for(int j=1;(i+(1<<j)-1)<=n;j++){
			stmax[i][j]=max(stmax[i][j-1],stmax[i+(1<<j-1)][j-1]);
			stmin[i][j]=min(stmin[i][j-1],stmin[i+(1<<j-1)][j-1]);
		}
	}
}
int getmax(int l,int r){
    int len=r-l+1;
	return max(stmax[l][prelog2[len]],stmax[r-(1<<prelog2[len])+1][prelog2[len]]);
}
int getmin(int l,int r){
    int len=r-l+1;
	return min(stmin[l][prelog2[len]],stmin[r-(1<<prelog2[len])+1][prelog2[len]]);
}
int main(){
	int q;
	scanf("%d %d",&n,&q);
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
	}
	init();
	while(q--){
		int l,r;
		scanf("%d %d",&l,&r);
		printf("%d\n",getmax(l,r)-getmin(l,r));
	}
	return 0;
}


poj 3264 Balanced Lineup ST算法