首页 > 代码库 > HDU--3466--Proud Merchants--01背包
HDU--3466--Proud Merchants--01背包
Proud Merchants
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2777 Accepted Submission(s): 1155
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
Sample Output
5 11
这是个有前提的背包问题,主要是判断物品出场的顺序,本人表示跟上一题一样,准备作死的节奏,就不解析了,等弄明白了再加上
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max(a,b) a>b?a:b
using namespace std;
struct node
{
int a,b,c;
}s[555];
bool cmp(const node &a,const node &b)
{
return a.b-a.a<b.b-b.a; //排序规则
}
int main (void)
{
int n,m,i,j,k,l;
int dp[5555];
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<n;i++)
{
scanf("%d%d%d",&s[i].a,&s[i].b,&s[i].c);
}
sort(s,s+n,cmp);
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++) //01背包
for(j=m;j>=s[i].b;j--)
dp[j]=Max(dp[j],dp[j-s[i].a]+s[i].c);
printf("%d\n",dp[m]);
}
return 0;
}
总结:今天就做了这两个题,一个是K大值的背包,一个是有前提的背包,这几天有得溜了!
HDU--3466--Proud Merchants--01背包
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。