首页 > 代码库 > HDU 4716 A Computer Graphics Problem(模拟啊 )

HDU 4716 A Computer Graphics Problem(模拟啊 )

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4716


Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use ‘.‘ as empty grids.
When the battery is empty, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.
 

Sample Input
2 0 60
 

Sample Output
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
 

Source
2013 ACM/ICPC Asia Regional Online —— Warmup2

代码如下:

#include <stdio.h>
#include <string.h>
int main()
{
    int t,i,j,n,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        char mp[20][20]= {"*------------*",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "|............|",
                          "*------------*"
                         };
        n/=10;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=12; j++)
                mp[11-i][j]='-';
        }
        printf("Case #%d:\n",cas++);
        for(i=0; i<12; i++)
        {
            for(j=0; j<14; j++)
            {
                printf("%c",mp[i][j]);
            }
            printf("\n");
        }
    }
    return 0;
}


HDU 4716 A Computer Graphics Problem(模拟啊 )