首页 > 代码库 > A Computer Graphics Problem 4176 2013上海邀请赛

A Computer Graphics Problem 4176 2013上海邀请赛

A Computer Graphics Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 968    Accepted Submission(s): 688


Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use ‘.‘ as empty grids.
When the battery is empty, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.
 

Sample Input
2 0 60
 

Sample Output
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
 

Source
2013 ACM/ICPC Asia Regional Online —— Warmup2

比较简单,思路可以自己找。
#include<cstdio>
int main()
{
  int t;
  int n,k=1;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
	printf("Case #%d:\n",k++);
	printf("*------------*\n");
	for(int i=0;i<10-n/10;i++)
		printf("|............|\n");
	for(int j=0;j<n/10;j++)
	printf("|------------|\n");
		printf("*------------*\n");
  }
  return 0;
}