首页 > 代码库 > hdu 1312 Red and Black(深搜)

hdu 1312 Red and Black(深搜)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10286    Accepted Submission(s): 6426


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 

Source
Asia 2004, Ehime (Japan), Japan Domestic
做好细节工作,迫在眉睫!!!本来测试数据三组都对了,最后一组怎么都不对,调试了一中午,才发现是map数组忘了初始化了。。。。
代码如下:
#include<stdio.h>
#include<string.h>
char map[1001][1001];
int visit[1001][1001];
int count,n,m;
void dfs(int a,int b)
{
	if(a<0||b<0||a>=1001||b>=1001)
	return ;
	if(!visit[a-1][b]&&map[a-1][b]=='.')
	{
		visit[a-1][b]=1; 
		count++;
		dfs(a-1,b);
	//	visit[n-1][m]=0;
	}
	if(!visit[a][b-1]&&map[a][b-1]=='.')
	{
		visit[a][b-1]=1;
		count++;
		dfs(a,b-1);
	//	visit[n][m-1]=0;
	}
	if(!visit[a+1][b]&&map[a+1][b]=='.')
	{
		visit[a+1][b]=1;
		count++;
		dfs(a+1,b);
	//	visit[n+1][m]=0;
	}	
	if(!visit[a][b+1]&&map[a][b+1]=='.')
	{
		visit[a][b+1]=1;
		count++;
		dfs(a,b+1);
	//	visit[n][m+1]=0;
	}
	else 
		return ;
}
int main()
{
	int i,j;
	while(~scanf("%d%d",&n,&m),n||m)
	{
		count=1;
		memset(visit,0,sizeof(visit));
		memset(map,'#',sizeof(map));//这个一定要加上,就因为这个疏忽,我足足调试了一中午。。。 
		for(i=0;i<m;++i)
		{
			scanf("%s",map[i]);
		}
		for(i=0;i<m;++i)
		{
			for(j=0;j<n;++j)
			{
				if(map[i][j]=='@')
				{
					dfs(i,j);
					printf("%d\n",count);
					break;
				}
			}
		}
	}
	return 0;
} 


 

hdu 1312 Red and Black(深搜)