首页 > 代码库 > HDoj-1312-Red and Black -BFS

HDoj-1312-Red and Black -BFS

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10064    Accepted Submission(s): 6276


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int t,m,n,X,Y;
char str[21][21];
void BFS(int x,int y)
{
    int xx,yy,i;
    if(x>=m||x<0||y<0||y>=n)
      return;
    for(i=0;i<4;i++)
    {
        xx=x+f[i][0];
        yy=y+f[i][1];
        if(xx<0||xx>=m||yy<0||yy>=n||str[xx][yy]=='#') continue;
           t++;
        str[xx][yy]='#';
        BFS(xx,yy);
    }
}
int main()
{
   int i,j;
   while(~scanf("%d%d",&n,&m),m+n)
   {
      t=1;
      getchar();
      for(i=0;i<m;i++)
      {
         for(j=0;j<n;j++)
         {
            scanf("%c",&str[i][j]);
            if(str[i][j]=='@')
            {
               X=i;
               Y=j;
            } 
         }
            getchar();
      }
       str[X][Y]='#';
       BFS(X,Y);
       printf("%d\n",t);
   }
 return 0;
}


HDoj-1312-Red and Black -BFS