首页 > 代码库 > POJ1703 Find them, Catch them 【并查集】

POJ1703 Find them, Catch them 【并查集】

Find them, Catch them

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
 

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
 

Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
 

Sample Input
1 5 5 A 1 2 D 1 2 A 1 2 D 2 4 A 1 4
 

Sample Output
Not sure yet. In different gangs. In the same gang.
 

Source
PKU

 维护关系的并查集。pre[i]表示i为第一个集合,pre[i+N]表示i为第2个集合。由于给定的关系是相对的,所以每次同时维护两种情况。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long LL;

#define maxn 100005

int pre[maxn << 1];

int ufind(int k) {
    int a = k, b;
    while(pre[k]) k = pre[k];
    while(a != k) {
        b = pre[a];
        pre[a] = k;
        a = b;
    }
    return k;
}

bool same(int a, int b) {
    return ufind(a) == ufind(b);
}

bool unite(int a, int b) {
    a = ufind(a);
    b = ufind(b);
    if(a == b) return false;
    pre[a] = b;
    return true;
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    int T, N, M, i, a, b;
    char ch[2];
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &N, &M);
        memset(pre, 0, sizeof(int) * (2 * N + 1));
        while(M--) {
            scanf("%s%d%d", ch, &a, &b);
            if(*ch == 'D') {
                unite(a, b + N);
                unite(a + N, b);
            } else {
                if(same(a, b + N))
                    printf("In different gangs.\n");
                else if(same(a, b)) 
                    printf("In the same gang.\n");
                else printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}


POJ1703 Find them, Catch them 【并查集】