首页 > 代码库 > [并查集] POJ 1703 Find them, Catch them

[并查集] POJ 1703 Find them, Catch them

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43132   Accepted: 13257

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18
原题大意:对于T组数据,每组数据有两个整数n,m代表有n个点,m次询问。
              接下来m行,每一行第一个字符为A,则回答1与2是否为一个集合,回答是,不是,或是不知道。
              第一个字符为D,则表示1与2不是一个集合。
解题思路:此题唯一与裸并查集不同的就是D表示的是不同。
              明显的是1+0为1,(1+1)%2==0,明显的是组成了一个循环结构,可以用向量的方式来解。
#include<stdio.h>
int father[150500],relation[150050];
void init(int n)
  {
  	 int i;
  	 for(i=1;i<=n;++i) father[i]=i;
  	 for(i=1;i<=n;++i) relation[i]=0;
  }
int find(int x)
  {
  	 int t;
  	 if(x==father[x]) return (x);
  	 t=father[x];
  	 father[x]=find(t);
  	 relation[x]=(relation[x]+relation[t])%2;
  	 return (father[x]);
  }
void merge(int x,int y)
  {
  	 int find_x=find(x);
  	 int find_y=find(y);
  	 if(find_x!=find_y) 
  	   {
  	      relation[find_x]=(relation[y]+1-relation[x]+2)%2;
  	      father[find_x]=find_y;
	   }
  }
int main()
  {
  	 int T,n,m,num=0;char c;int x,y;
  	 scanf("%d",&T);
  	 while(T--)
  	   {
  	   	  scanf("%d%d",&n,&m);
  	   	  init(n);
  	   	  while(m--)
  	   	    {
  	   	      getchar();
  	   	      scanf("%c%d%d",&c,&x,&y);
  	   	      if(c==‘D‘)
  	   	        {
  	   	           merge(x,y);
				}else
			  if(c==‘A‘)
			    {
			      if(find(x)!=find(y))
			        {
			           printf("Not sure yet.\n");
			           continue;
					}else
				  if(relation[x]==relation[y]) 
				    {
				       printf("In the same gang.\n");
				       continue;
					}else
				  if(relation[x]!=relation[y])
				    printf("In different gangs.\n");
				}
			}
	   }
  	 return 0;
  }

  

           

[并查集] POJ 1703 Find them, Catch them