首页 > 代码库 > hdu 1496 Equations(暴力,哈希表 剪枝)

hdu 1496 Equations(暴力,哈希表 剪枝)

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5630    Accepted Submission(s): 2237


Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
1 2 3 -4 1 1 1 1
 

Sample Output
39088 0
 

Author
LL
 

Source
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛
代码如下:
#include<stdio.h>
int main()
{
	int a,b,c,d,i,j,k,count,l,s1,s2;
	int pow[110];
	while(~scanf("%d%d%d%d",&a,&b,&c,&d))
	{
		count=0;
		for(i=1;i<101;++i)
		pow[i]=i*i;
		if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
		{
			printf("0\n");
			continue;
		}
		for(i=1;i<101;++i)
		{
			for(j=1;j<101;++j)
			{
				s1=a*pow[i]+b*pow[j];
				if(s1>0&&c>0&&d>0||s1<0&&c<0&&d<0)
				continue;
				for(k=1;k<101;++k)
				{
					s2=s1+c*pow[k];
					if(s2%d==0)
					{
						s2/=-d;
						if(s2>0)
						{
							for(l=1;l<101;++l)
							{
								if(s2==pow[l])
								{
									count++;
									break;
								}
							}
						}
					}
				}
			}
		}
		printf("%d\n",count*16);
	}
	return 0;
}


 

hdu 1496 Equations(暴力,哈希表 剪枝)