首页 > 代码库 > 数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

  数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

提示

不得使用数组。

来源

 

示例程序

/*************************************************************************
	> File Name: 数据结构实验之链表三:链表的逆置.c
	> Author: ttop5
	> Blog: www.ttop5.net
	> Mail: 1427154738@qq.com
	> Created Time: 2014年12月10日 星期三 20时57分20秒
 ************************************************************************/
#include<stdio.h>
#include<malloc.h>

struct node
{
    int data;
    struct node *next;
};
//逆序建立链表
struct node *Creat()
{
    struct node *head,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    p=(struct node *)malloc(sizeof(struct node));
    scanf("%d",&p->data);
    while(p->data!=-1)
    {
        p->next=head->next;
        head->next=p;
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
    }
    return (head);
}

int main()
{
    struct node *head;
    head=Creat();
    if(head->next!=NULL)
    {
        printf("%d",head->next->data);
        head=head->next;
    }
    while(head->next!=NULL)
    {
        printf(" %d",head->next->data);
        head=head->next;
    }
    printf("\n");
    return 0;
}


数据结构实验之链表三:链表的逆置