首页 > 代码库 > [JAVA][ZOJ 1016][Parencodings]
[JAVA][ZOJ 1016][Parencodings]
Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:
- By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
- By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
- <p>
- </p>import java.io.BufferedInputStream;
- import java.util.Scanner;
- public class Main {
- public static void main(String[] args) throws InterruptedException {
- Scanner sc = new Scanner(System.in);
- int n = sc.nextInt();
- for (int i = 0; i < n; i++) {
- int len = sc.nextInt();
- int P[] = new int[len];// P shows how many left parentheses have been seen since each right parentheses
- int W[] = new int[len];// W shows how many left parentheses have been seen within a pair of parentheses
- // EG:<><>,W=11
- // EG:<<>>,W=12
- // EG:<<<><>>>,W=1134
- char str[] = new char[len * 2];
- int posInP = 0;
- for (int posInStr = 0; posInStr < len; posInStr++) {
- P[posInStr] = sc.nextInt();
- if (posInStr == 0) {// the first P-code
- for (; posInP < P[posInStr]; posInP++) {
- str[posInP] = ‘<‘;
- }
- str[posInP++] = ‘>‘;
- } else {
- if (P[posInStr] > P[posInStr - 1]) {
- for (int k = 0; k < (P[posInStr] - P[posInStr - 1]); k++) {
- str[posInP++] = ‘<‘;
- }
- str[posInP++] = ‘>‘;
- } else {// if the next num is the same of the last
- str[posInP++] = ‘>‘;
- }
- }
- }
- // check for W array
- int posInW = 0;
- for (int j = 0; j < len * 2; j++) {
- if (str[j] == ‘<‘) {
- continue;
- }
- int RightParentheses = 1;
- for (int j2 = j - 1; j2 >= 0; j2--) {
- if (str[j2] == ‘>‘) {
- RightParentheses++;
- } else {
- RightParentheses--;
- W[posInW]++;
- }
- if (RightParentheses == 0) {
- posInW++;
- break;
- }
- }
- }
- int j;
- for (j = 0; j < len - 1; j++) {
- System.out.print(W[j] + " ");
- }
- System.out.print(W[j]);
- System.out.println();
- }
- }
- }
PE了好多次,在Eclipse中复制2个testcase,刚复制完就出现第一个的结果,然后按回车就出现另一个结果,本来以为是这个问题,改为把所有的结果收集然后集中输出后又显示RE,最后发现居然是输出的问题,最后一个数字后面不输出空格,这细节真心不是坑爹嘛。。。。
[JAVA][ZOJ 1016][Parencodings]