首页 > 代码库 > POJ1979_Red and Black【DFS】

POJ1979_Red and Black【DFS】

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23182Accepted: 12504


Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13


Source

Japan 2004 Domestic


题目大意:给你一个房间,房间由一格格砖组成,有黑砖和红砖,只能站在黑砖上,

现在你站在其中一块黑砖上,且只能向相邻的黑砖上走,问:最多有多少块黑砖可以走

思路:数据规模不大,直接DFS上下左右四个方向

#include<stdio.h>
#include<string.h>

char map[25][25],vis[25][25];
int ans,W,H;
void dfs(int i,int j)
{
    if(map[i][j] == '#')
        return;
    if(i < 0 || i >= H || j < 0 || j >= W)
        return;
    if(vis[i][j]==0)
    {
        ans++;
        vis[i][j] = 1;
        dfs(i-1,j);
        dfs(i,j-1);
        dfs(i,j+1);
        dfs(i+1,j);
        return;
    }
}
int main()
{
    while(~scanf("%d%d",&W,&H) && (W||H))
    {
        memset(map,0,sizeof(map));
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < H; i++)
        {
            getchar();
            scanf("%s",map[i]);
        }
        int posi,posj;
        for(int i = 0; i < H; i++)
            for(int j = 0; j < W; j++)
                if(map[i][j]=='@')
                {
                    posi = i;
                    posj = j;
                }
        ans = 0;
        dfs(posi,posj);
        printf("%d\n",ans);
    }

    return 0;
}


POJ1979_Red and Black【DFS】