首页 > 代码库 > CISCO HSRP

CISCO HSRP

技术分享



SW1:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/1

 no switchport

 ip address 192.168.60.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet0/2

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan10

 ip address 192.168.40.1 255.255.255.0

 standby version 2

 standby 10 ip 192.168.40.254

 standby 10 priority 200

 standby 10 preempt

 standby 10 track FastEthernet0/1

!

router rip

 passive-interface Vlan10

 network 192.168.40.0

 network 192.168.60.0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

 login

!

!

!

end

SW2:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/1

 no switchport

 ip address 192.168.50.2 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet0/2

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface FastEthernet0/3

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan10

 ip address 192.168.40.2 255.255.255.0

 standby version 2

 standby 10 ip 192.168.40.254

 standby 10 priority 150

 standby 10 preempt

!

router rip

 passive-interface Vlan10

 network 192.168.40.0

 network 192.168.50.0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

 login

!

!

!

end

ROUTE:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 ip address 192.168.60.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/0

 ip address 192.168.50.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet1/1

 ip address 10.10.10.2 255.255.255.0

 duplex auto

 speed auto

!

router rip

 network 10.0.0.0

 network 192.168.50.0

 network 192.168.60.0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

 login

!

!

!

end

SW7:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

 switchport mode trunk

!

interface FastEthernet0/2

!

interface FastEthernet0/3

 switchport access vlan 10

 switchport mode access

!

interface FastEthernet0/4

 switchport mode trunk

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 no ip address

 shutdown

!

!

!

!

line con 0

!

line vty 0 4

 login

line vty 5 15

 login

!

!

end

SW8:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

 switchport mode trunk

!

interface FastEthernet0/2

 switchport access vlan 10

!

interface FastEthernet0/3

 switchport access vlan 10

!

interface FastEthernet0/4

 switchport mode trunk

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 no ip address

 shutdown

!

!

!

!

line con 0

!

line vty 0 4

 login

line vty 5 15

 login

!

!

end

SW1:

技术分享

SW2:

技术分享


本文出自 “冯修乔” 博客,请务必保留此出处http://fxq666.blog.51cto.com/12117109/1924252

CISCO HSRP