首页 > 代码库 > Game(杭电5011)

Game(杭电5011)

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 489    Accepted Submission(s): 378


Problem Description
Here is a game for two players. The rule of the game is described below: 

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing) 

● If after a player‘s turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads in the i-th pile.
 

Output
For each test case, if the first player can win the game, ouput "Win" and if he can‘t, ouput "Lose"
 

Sample Input
1 1 2 1 1 3 1 2 3
 

Sample Output
Win Lose Lose
//尼姆博弈简单应用。 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,n,a,t;
	while(scanf("%d",&n)!=EOF)
	{
		t=0;
		while(n--)
		{
			scanf("%d",&a);
			t^=a;
		}
		if(t==0)
		printf("Lose\n");
		else
		printf("Win\n");
	}
} 


Game(杭电5011)