首页 > 代码库 > HDU 5011 Game(Nim博弈)

HDU 5011 Game(Nim博弈)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5011


贴一发博弈的链接的链接:http://blog.csdn.net/u012860063/article/details/21816635


Problem Description
Here is a game for two players. The rule of the game is described below: 

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing) 

● If after a player‘s turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads in the i-th pile.
 

Output
For each test case, if the first player can win the game, ouput "Win" and if he can‘t, ouput "Lose"
 

Sample Input
1 1 2 1 1 3 1 2 3
 

Sample Output
Win Lose Lose
 

Source
2014 ACM/ICPC Asia Regional Xi‘an Online


代码如下:

#include<cstdio>
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int sum, a;
        scanf("%d",&sum);
        for(int i=1; i<n; i++)
        {
            scanf("%d",&a);
            sum^=a;
        }
        if(!sum)
            printf("Lose\n");
        else
            printf("Win\n");
    }
    return 0;
}


HDU 5011 Game(Nim博弈)