首页 > 代码库 > NYOJ 233 Sort it【冒泡排序】

NYOJ 233 Sort it【冒泡排序】

求解交换次数,用冒泡刚好


Sort it

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6
来源
ZJFC 2009-3 Programming Contest
上传者
张洁烽


#include<stdio.h>
#include<string.h>
int arr[1100];
int main()
{
	int n,i,j,sum,t;
	while(~scanf("%d",&n))
	{
		sum=0;
		memset(arr,0,sizeof(arr));
		for(i=0;i<n;i++)
			scanf("%d",&arr[i]);
		for(i=1;i<=n-1;i++)
			for(j=0;j<=n-i-1;j++)
				if(arr[j]>arr[j+1])
				{
					t=arr[j];
					arr[j]=arr[j+1];
					arr[j+1]=t;
					sum++;
				}
		printf("%d\n",sum);		
	}
	
	return 0;
}







NYOJ 233 Sort it【冒泡排序】