首页 > 代码库 > HDOJ 5099 Comparison of Android versions 坑题
HDOJ 5099 Comparison of Android versions 坑题
现场赛的时候错了十四次。
。
。。。
Comparison of Android versions
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 76 Accepted Submission(s): 60
Problem Description
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B.
The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.
The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.
Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.
Please develop a program to compare two Android build numbers.
The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.
The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.
Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.
Please develop a program to compare two Android build numbers.
Input
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process.
Each test case consists of a single line containing two build numbers, separated by a space character.
Each test case consists of a single line containing two build numbers, separated by a space character.
Output
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows:
● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.
Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.
If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.
Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.
If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
Sample Input
2 FRF85B EPF21B KTU84L KTU84M
Sample Output
Case 1: > > Case 2: = <
Source
field=problem&key=2014%C9%CF%BA%A3%C8%AB%B9%FA%D1%FB%C7%EB%C8%FC%A1%AA%A1%AA%CC%E2%C4%BF%D6%D8%CF%D6%A3%A8%B8%D0%D0%BB%C9%CF%BA%A3%B4%F3%D1%A7%CC%E1%B9%A9%CC%E2%C4%BF%A3%A9&source=1&searchmode=source" style="color:rgb(26,92,200); text-decoration:none">2014上海全国邀请赛——题目重现(感谢上海大学提供题目)
#include <iostream> #include <cstdio> #include <cstring> #include <algorithm> using namespace std; char s1[10],s2[10]; char ONE,TWO; void BJ1() { if(s1[0]<s2[0]) ONE='<'; else if(s1[0]==s2[0]) ONE='='; else ONE='>'; } void BJ2() { if(s1[2]<s2[2]) TWO='<'; else if(s1[2]==s2[2]) { int day1=(s1[3]-'0')*10+s1[4]-'0'; int day2=(s2[3]-'0')*10+s2[4]-'0'; if(day1<day2) TWO='<'; else if(day1==day2) { if(s1[1]==s2[1]) { if(s1[5]<s2[5]) TWO='<'; else if(s1[5]==s2[5]) TWO='='; else TWO='>'; } else TWO='='; } else TWO='>'; } else TWO='>'; } int main() { int T_T; int cas=1; scanf("%d",&T_T); while(T_T--) { scanf("%s%s",s1,s2); if(strlen(s1)<6) s1[5]='A'; if(strlen(s2)<6) s2[5]='A'; BJ1();BJ2(); printf("Case %d: %c %c\n",cas++,ONE,TWO); } return 0; }
HDOJ 5099 Comparison of Android versions 坑题
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。