首页 > 代码库 > 二叉排序树
二叉排序树
题目描述:
输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。
输入:
输入第一行包括一个整数n(1<=n<=100)。
接下来的一行包括n个整数。
输出:
可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
每种遍历结果输出一行。每行最后一个数据之后有一个空格。
样例输入:
5 1 6 5 9 8
样例输出:
1 6 5 9 8 1 5 6 8 9 5 8 9 6 1
提示:
输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
struct node {
node *lchild;
node *rchild;
int c;
}tree[110];
int loc;
node* creat(){
tree[loc].lchild = tree[loc].rchild = NULL;
loc++;
return &tree[loc-1];
}
void post(node *t){
if (t->lchild){
post(t->lchild);
}
if (t->rchild){
post(t->rchild);
}
printf ("%d ",t->c);
}
void mid(node *t){
if (t->lchild){
mid(t->lchild);
}
printf ("%d ",t->c);
if (t->rchild){
mid(t->rchild);
}
}
void pre(node *t){
printf ("%d ",t->c);
if (t->lchild){
pre(t->lchild);
}
if (t->rchild){
pre(t->rchild);
}
}
node * insert (node *t, int x){
if (!t){
t=creat();
t->c=x;
return t;
}
else if (t->c>x){
t->lchild=insert(t->lchild,x);
}
else if (t->c<x){
t->rchild=insert(t->rchild,x);
}
return t;
}
int main(){
int n;
while (cin>>n){
loc=0;
int x;
node *t=NULL;
while(n--){
cin>>x;
t=insert(t,x);//insert函数有返回值,一定要写t=intsert(),不要只写insert。
}
pre(t); cout<<endl;
mid(t);cout<<endl;
post(t); cout<<endl;
}
return 0;
}
node *t=null;只是建立了一个空指针,并不是建立了一个节点。建立节点在insert函数里面,引用了creat函数。
二叉树的建立原理:先建立了一个110大小的节点数组,然后creat函数只是返回指向每个数组元素的指针,形成了树。
loc要定义为全局变量,应为creat函数里面用到了loc。而不只是主函数里面用了loc
二叉排序树
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。