首页 > 代码库 > hdu 5154 Harry and Magical Computer(BestCoder Round #25)

hdu 5154 Harry and Magical Computer(BestCoder Round #25)

Harry and Magical Computer

                                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                             Total Submission(s): 472    Accepted Submission(s): 222


Problem Description
In reward of being yearly outstanding magic student, Harry gets a magical computer. When the computer begins to deal with a process, it will work until the ending of the processes. One day the computer got n processes to deal with. We number the processes from 1 to n. However there are some dependencies between some processes. When there exists a dependencies (a, b), it means process b must be finished before process a. By knowing all the m dependencies, Harry wants to know if the computer can finish all the n processes.
 

Input
There are several test cases, you should process to the end of file.
For each test case, there are two numbers n m on the first line, indicates the number processes and the number of dependencies. 1n100,1m10000
The next following m lines, each line contains two numbers a b, indicates a dependencies (a, b). 1a,bn
 

Output
Output one line for each test case. 
If the computer can finish all the process print "YES" (Without quotes).
Else print "NO" (Without quotes).
 

Sample Input
3 2 3 1 2 1 3 3 3 2 2 1 1 3
 

Sample Output
YES NO
 

Source
BestCoder Round #25
 

     

       判断拓扑排序是否能够完成,拓扑排序不能完成的条件是没有环,只要判断图里是否有环是否就可以了,用flody和深搜应该都可以吧,我用的flody做的。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int map[150][150];
int n,m;
void flody()
{
    for(int k=1;k<=n;k++)
       for(int i=1;i<=n;i++)
           for(int j=1;j<=n;j++)
               if(map[i][k]&&map[k][j])
                   map[i][j]=1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        int sign=0;
        int a,b;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            if(a==b)
            {
                sign=1;
                continue;
            }
            map[a][b]=1;
        }
        if(sign)
        printf("NO\n");
        else
        {
            flody();
            for(int i=1;i<=n;i++)
            if(map[i][i])
            sign=1;
            if(sign)
            printf("NO\n");
            else
            printf("YES\n");
        }

    }
    return 0;
}


hdu 5154 Harry and Magical Computer(BestCoder Round #25)