首页 > 代码库 > HDU2071 Max Num【水题】

HDU2071 Max Num【水题】

Max Num


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15557    Accepted Submission(s): 9670

Problem Description
There are some students in a class, Can you help teacher find the highest student .
 
Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 
Output
For each case output the highest height, the height to two decimal plases;
 
Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
 
Sample Output
180.00
182.00
 
Author
Lily
 
Source

浙江工业大学网络选拔赛


题目大意:给你N个浮点数,求最大值。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        int N;
        cin >> N;
        double d,Max = -1;
        while(N--)
        {
            cin >> d;
            if(d > Max)
                Max = d;
        }
        printf("%.2lf\n",Max);
    }

    return 0;
}


HDU2071 Max Num【水题】