首页 > 代码库 > hdu 1217 Arbitrage Floyd||SPFA

hdu 1217 Arbitrage Floyd||SPFA

转载请注明出处:http://acm.hdu.edu.cn/showproblem.php?pid=1217

Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output
Case 1: Yes Case 2: No

Source
University of Ulm Local Contest 1996 

题意:给几个国家,然后给这些国家之间的汇率。判断能否通过这些汇率差进行套利交易。

Floyd的算法可以求出任意两点间的最短路径,最后比较本国与本国的汇率差,如果大于1,则可以。否则不可以。


代码如下:

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
using namespace std;
#define N 47
double M[N][N];
map<string,int>mm;
void init( int n)
{
	for(int i = 1 ; i <= n ; i++ )
	{
		for(int j = 1 ; j <= n ;j++)
		{
			if(i == j)
				M[i][j] = 1.0; //自身的汇率为1
			else
				M[i][j] = 0;
		}
	}
}
void floyd(int n)
{
	for(int k = 1 ; k <= n ;k++)
	{
		for(int i = 1 ; i <= n ;i++ )
		{
			for( int j = 1 ; j <= n ;j++ )
			{
				if(M[i][j] < M[i][k] * M[k][j])
				{
					M[i][j] = M[i][k] * M[k][j];
				}
			}
		}
	}
}
int main()
{

	char s1[147],s2[147],s[147];
	int n, m,cnt = 0;
	double gate;
	while(~scanf("%d",&n) && n)
	{
		init(n);
		for( int i = 1 ; i <= n ;i++)
		{
			scanf("%s",s);
			mm[s] = i;
		}
		scanf("%d",&m);
		for( int j = 1 ; j <= m ; j++)
		{
			scanf("%s%lf%s",s1,&gate,s2);
			M[mm[s1]][mm[s2]] = gate;
		}
		floyd( n );
		int flag = 0;
		for( i = 1 ; i<= n ; i++)
		{
			if(M[i][i] > 1)
			{
				flag = 1;
				break;
			}
		}
		if( flag == 1)
		{
			printf("Case %d: Yes\n",++cnt);
				continue;
		}
		printf("Case %d: No\n",++cnt);
	}
	return 0;
}

附SPFA代码:

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
using namespace std;

const int L = 35;
const double inf = 1000000;
map<string,int> mat;
int n,m;
char str[105],s1[105],s2[105];
double trip[35][35],dis[35];

int SPFA(int src)
{
    queue<int> Q;
    int vis[35],i;
    int num[35];
    for(i = 1; i<=n; i++)
        vis[i] = dis[i] = num[i] = 0;
    while(!Q.empty())
        Q.pop();
    dis[src] = 1.0;
    vis[src] = 1;
    Q.push(src);
    while(!Q.empty())
    {
        int now = Q.front();
        Q.pop();
        vis[now] = 0;
        for(i = 1; i<=n; i++)
        {
            if(dis[now]*trip[now][i]>dis[i])
            {
                dis[i] = dis[now]*trip[now][i];
                if(dis[src]>1.0)
                    return 1;
                if(!vis[i])
                {
                    vis[i] = 1;
                    Q.push(i);
                }
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,cas = 1;
    double w;
    while(~scanf("%d",&n),n)
    {
        mat.clear();
        for(i = 1; i<=n; i++)
            for(j = 1; j<=n; j++)
                trip[i][j] = (i==j)?1.0:0;
        for(i = 1; i<=n; i++)
        {
            scanf("%s",str);
            mat[str] = i;
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%lf%s",s1,&w,s2);
            trip[mat[s1]][mat[s2]] = w;
        }
        int flag = 0;
        for(i = 1; i<=n; i++)
        {
            if(SPFA(i))
            {
                flag = 1;
                break;
            }
        }
        printf("Case %d: %s\n",cas++,flag?"Yes":"No");
    }

    return 0;
}