首页 > 代码库 > poj 3278 Catch That Cow(广搜)

poj 3278 Catch That Cow(广搜)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45087 Accepted: 14116

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

题意  告诉你两个点 n   k   计算从 n到k 走的最短步数  移动方式 向n+1  or   n-1  or  n*2;

基本广搜水题  三个方向 搜索最短路径

#include<iostream>
#include<cstdio>
#include<cstring>
const int M=200005;
using namespace std;
typedef class{
    public:
    int x;
    int step;

}wz;
wz q[M];
int vis[M];
int n,k;
int bfs()
{
    int front=0,rear=0;
    q[rear].x=n;
    q[front].x=n;
    q[rear++].step=0;
    vis[n]=1;

    while(front<rear)
    {
       wz w=q[front++];
        if(w.x==k)
            return w.step;
        if(w.x-1>=0&&!vis[w.x-1])
        {
            vis[w.x-1]=1;
            q[rear].x=w.x-1;
            q[rear++].step=w.step+1;
        }
        if(w.x+1<=k&&!vis[w.x+1])
        {
            vis[w.x+1]=1;
            q[rear].x=w.x+1;
            q[rear++].step=w.step+1;
        }
        if(w.x<=k&&!vis[2*w.x])
        {
            vis[2*w.x]=1;
            q[rear].x=w.x*2;
            q[rear++].step=w.step+1;
        }

    }
}
int main()
{
    int i;
    while(cin>>n>>k)
    {
        memset(vis,0,sizeof vis);
          cout<<bfs()<<endl;
    }

    return 0;
}