首页 > 代码库 > HDOJ1198 Farm Irrigation 【并查集】

HDOJ1198 Farm Irrigation 【并查集】

Farm Irrigation
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5051    Accepted Submission(s): 2167

Problem DescriptionBenny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.
Figure 1
Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a mapADCFJKIHEthen the water pipes are distributed like
Figure 2
Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show. InputThere are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50. OutputFor each test case, output in one line the least number of wellsprings needed. Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
2 3

思路是开始将喷泉数赋值为土地块数,然后每次判断右边和下边的点是否与该点联通,若联通再判断是否属于同一个集合,若不属于同一个集合则喷泉数减一并合并成同一个集合。感觉这题貌似也可以用深搜~

//并查集
#include <stdio.h>
struct Node{
	bool up, down, left, right;
}node[] = 
{1, 0, 1, 0, //A
 1, 0, 0, 1, //B 
 0, 1, 1, 0, //C
 0, 1, 0, 1, //D
 1, 1, 0, 0, //E
 0, 0, 1, 1, //F
 1, 0, 1, 1, //G
 1, 1, 1, 0, //H
 0, 1, 1, 1, //I
 1, 1, 0, 1, //J
 1, 1, 1, 1};//K
 
char a[52][52];
 
struct NODE{
	int r, c;
}pre[52][52];

NODE find(NODE k){ //查找与压缩
	NODE i = k;
	while(!(i.r == pre[i.r][i.c].r && i.c == pre[i.r][i.c].c))
		i = pre[i.r][i.c];
	NODE j = k, t;
	while(j.r != i.r || j.c != i.c){
		t = pre[j.r][j.c];
		pre[j.r][j.c] = i;
		j = t;
	}
	return i;
}
 
int main(){
	int m, n, sum;
	NODE x, y, z;
	char ch;
	while(scanf("%d%d", &m, &n)){
		if(m < 0 || n < 0) break;
		
		sum = n * m;
		
		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j){
				pre[i][j].r = i;
				pre[i][j].c = j;
			}
		
		getchar();
		for(int i = 1; i <= m; ++i)
			gets(a[i] + 1);
		
		for(int i = 1; i <= m; ++i){
			for(int j = 1; j <= n; ++j){
				x = find(pre[i][j]);
				y = find(pre[i][j+1]);
				z = find(pre[i+1][j]);
			
				if(j < n && node[a[i][j]-‘A‘].right && node[a[i][j+1]-‘A‘].left){
					if(x.r != y.r || x.c != y.c){ //如果两点联通但又不在一个集合
						--sum;
						pre[y.r][y.c] = x; //联通
					}
				}
				
				if(i < m && node[a[i][j]-‘A‘].down && node[a[i+1][j]-‘A‘].up){
					if(x.r != z.r || x.c != z.c){ 
						--sum;
						pre[z.r][z.c] = x; 
					}
				}				
			}
		}
		
		printf("%d\n", sum);
	}
	return 0;
}




HDOJ1198 Farm Irrigation 【并查集】