首页 > 代码库 > NYOJ-269 VF
NYOJ-269 VF
VF
时间限制:1000 ms | 内存限制:65535 KB
难度:2
- 描述
- Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
- 输入
- There are multiple test cases.
Integer S (1 ≤ S ≤ 81). - 输出
- The milliard VF value in the point S.
- 样例输入
1
- 样例输出
10
题意:输入一个数s,求1-10^9中,每个数的各位数字之和为s的数有几个
dp[i][j]表示前 j 位数字之和为 i 的情况的数量
当 i 〉1 时,假设第 j 位为 k ,那么前 j - 1 的和就是 i - k;
由此得出状态转移方程dp[i][j]=dp[i][j]+dp[i-k][j-1];
01.
#include<iostream>
02.
using
namespace
std;
03.
int
dp[85][15];
04.
int
main()
05.
{
06.
for
(
int
i=0;i<10;i++)
07.
dp[0][i]=1;
08.
for
(
int
i=1;i<82;i++)
09.
for
(
int
j=1;j<10;j++)
//前j位之和为i
10.
for
(
int
k=0;k<10&&i-k>=0;k++)
//第j位为k,使前j-1位为i-k
11.
if
(dp[i-k][j-1])
//如果前面的数字能组合成i-k
12.
dp[i][j]+=dp[i-k][j-1];
13.
int
s;
14.
while
(cin>>s)
15.
{
16.
if
(s==1)
17.
cout<<10<<endl;
18.
else
19.
cout<<dp[s][9]<<endl;
20.
}
21.
return
0;
22.
}
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。