首页 > 代码库 > hdu 2602 Bone Collector

hdu 2602 Bone Collector

Bone Collector

                                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                      Total Submission(s): 28513    Accepted Submission(s): 11634


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
 

Recommend
lcy

简单0 1背包模板题 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int i,j,n,V,cas;
    int dp[1005],v[1005],w[1005];
    cin>>cas;
    while(cas--)
    {
        cin>>n>>V;
        memset(dp,0,sizeof dp);
        for(i=0;i<n;i++)
            cin>>w[i];
        for(i=0;i<n;i++)
            cin>>v[i];
            for(i=0;i<n;i++)
                for(j=V;j>=v[i];j--)
            {
                dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
            }

           cout<<dp[V]<<endl;
    }
    return 0;
}


hdu 2602 Bone Collector