首页 > 代码库 > Sticks(回溯和剪枝和关于局部变量的问题)

Sticks(回溯和剪枝和关于局部变量的问题)

做这道题要哭了= =
之前把所有的变量都定义成全局变量,结果提交时老是RT,找不到错。后来改成局部变量就ac了= =。

Sticks(3.4.2)
Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u
SubmitStatus

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5




#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int n,num[69];
int pd[69];
int cmp(int a,int b)
{
	return a>b;
}
int dfs(int len,int s,int nu)
{
	int i;
    if(s==0&&nu==0)//如果剩下的长度和剩下的木棒数为0,则成功
		return len;
    if(s==0)//如果剩下的长度为0,则重新赋值
		s=len;
    for(i=0;i<n;i++)
    {
        if(pd[i]==1)
			continue;
        if(s>=num[i])
        {
            pd[i]=1;
            if(dfs(len,s-num[i],nu-1))
				return  len;	
			pd[i]=0;//如果不成功,则当前棒不使用
            if(num[i]==s||s==len)
				break;
            while(num[i]==num[i+1])
				i++;			
        }
    }
	return 0;
}
int main()
{
    while(cin>>n&&n)
    {
		int i;
		int sum;
        sum=0;
		int len,k;
		for(i=0;i<n;i++)
		{
			cin>>num[i];
			sum=sum+num[i];
		}
		sort(num,num+n,cmp);
		for(len=num[0];len<=sum;len++)
		{
			memset(pd,0,sizeof(pd));
			if(sum%len==0)
			{
				k=dfs(len,0,n);
				if(k)
					break;
			}
		}
		cout<<k<<endl;
    }
    return 0;
}
/*
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
*/