首页 > 代码库 > poj3267

poj3267

题目链接:

啊哈哈,选我

题目:

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7963 Accepted: 3734

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

USACO 2007 February Silver


这里有个链接讲解的非常仔细,值得借鉴。

传送门

因为讲解的非常仔细,我说一下思路。。就是逆向枚举,看能否匹配,能匹配就进行更新,不能匹配就是最坏的情况,进行删除操作。。

代码为:


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=300+10;
char dic[600+10][25+10];
char mes[maxn];
int dp[maxn];
int w,l;
int main()
{
    while(~scanf("%d%d",&w,&l))
    {
        scanf("%s",mes);
        for(int i=1;i<=w;i++)
            scanf("%s",dic[i]);
        int dicpd,mespd;
        memset(dp,INF,sizeof(dp));
        dp[l]=0;
        for(int i=l-1;i>=0;i--)
        {
            dp[i]=dp[i+1]+1;
            for(int j=1;j<=w;j++)
            {
                int len=strlen(dic[j]);
                if(l-i>=len&&mes[i]==dic[j][0])
                {
                   mespd=i,dicpd=0;
                   while(mespd<l)
                   {
                        if(mes[mespd]==dic[j][dicpd])
                              dicpd++;
                        mespd++;
                        if(dicpd==len)
                         {
                            dp[i]=min(dp[i],dp[mespd]+mespd-dicpd-i);
                            break;
                        }
                   }
                }
            }
        }
        printf("%d\n",dp[0]);
    }
    return 0;
}