首页 > 代码库 > HDU 1712 ACboy needs your help(DP)

HDU 1712 ACboy needs your help(DP)

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 


Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 


Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 


Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 


Sample Output
3 4 6


题意:n个课程,最多有m天可以用,每个课程花费不同的天数得到的收益不同,第i个课程花费j天来学那么收益为a[i][j],问如何安排收益最大。

首先明确每个课程只会上一次。设dp[i][j]为前i个课程花费j天的最大收益,枚举当前i课程的所有需要的天数k,并选择学还是不学对应的a[i][k]。

于是有 dp[i][j] = max( dp[i][j] , dp[i-1][j] , dp[i-1][j-k]+a[i][k] )  (1<=k<=j) .

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int a[105][105] , dp[105][105],n,m;
int Max(int a,int b,int c) {
    return max( max(a,b) , c );
}
int main()
{
    while (~scanf("%d%d",&n,&m) && n+m) {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&a[i][j]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                for(int k=1;k<=j;k++)
                    dp[i][j] = Max( dp[i][j] ,dp[i-1][j] ,dp[i-1][ j-k ]+a[i][k] );
        printf("%d\n",dp[n][m]);
    }
    return 0;
}