首页 > 代码库 > HDOJ 1702 ACboy needs your help again!

HDOJ 1702 ACboy needs your help again!

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1702


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3512    Accepted Submission(s): 1797


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.
 

Sample Input
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
1 2 2 1 1 2 None 2 3
 

Source
2007省赛集训队练习赛(1)
 

题意: 略。

题解: 简单栈和队列只是考查

AC代码:

#include<iostream>
#include<string>
#define maxn 1000000+5
using namespace std;
int vec[maxn],top,rear,t,n;
string str,cstack="FILO",cqueue="FIFO",in="IN",out="OUT",no="None";
int main()
{
	cin.sync_with_stdio(false);
	cin>>t;
	while(t--)
	{
		cin>>n>>str;
		top=rear=0;
		int flag=1,num;
		if(str==cqueue) flag=0;
		while(n--)
		{
			if(flag){   //栈 
			cin>>str;
			if(str==in){  //进栈 
				cin>>num; vec[top++]=num; 
			} 
			else {  //出栈 
				if(top) //栈不为空 
				cout<<vec[--top]<<endl;	
				else cout<<no<<endl;
			}
			}
			else {     //队列 
				cin>>str;
				if(str==in){//入队 
					cin>>num;vec[top++]=num; 
				}
				else { //出队 
					if(top!=rear)//队列不为空 
						cout<<vec[rear++]<<endl;
					else cout<<no<<endl;
				}
			}
			
		}
	}
	return 0;
}





HDOJ 1702 ACboy needs your help again!