首页 > 代码库 > 杭电 4681
杭电 4681
Couple doubi
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 743 Accepted Submission(s): 537
Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
Input
Multiply Test Cases.
In the first line there are two Integers k and p(1<k,p<2^31).
In the first line there are two Integers k and p(1<k,p<2^31).
Output
For each line, output an integer, as described above.
Sample Input
2 320 3
Sample Output
YESNO
Author
FZU
Source
2014 Multi-University Training Contest 1
费马小定理 最终只需要判定k/(p-1)是否是奇数就行了
代码如下
#include<stdio.h>
int main()
{
int p,k,m;
while(~scanf("%d%d",&k,&p))
{
m=k/(p-1);
if(m&1)//if(m%2==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
int main()
{
int p,k,m;
while(~scanf("%d%d",&k,&p))
{
m=k/(p-1);
if(m&1)//if(m%2==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。