首页 > 代码库 > 贪心 没什么可以说的,还是要注意细节
贪心 没什么可以说的,还是要注意细节
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
Output
Sample Input
Sample Output
#include<stdio.h>
#include<string.h>
main()
{
int i,n,m,g,t,sum,max,min;
int x[300];
int y[300];
int z[300];
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
sum=0;
memset(z,0,sizeof(z));
for(i=1;i<=m;i++)
{scanf("%d %d",&x[i],&y[i]);
if(x[i]>y[i])
{
t=x[i];
x[i]=y[i];
y[i]=t;
}}
for(i=1;i<m;i++)
for(g=i+1;g<=m;g++)
{
if(y[i]<y[g])
{ t=x[i];
x[i]=x[g];
x[g]=t;
t=y[i];
y[i]=y[g];
y[g]=t; }
}
for(i=1;i<m;i++)
for(g=i+1;g<=m;g++)
{
if(y[i]==y[g]&&x[i]<x[g])
{ t=x[i];
x[i]=x[g];
x[g]=t;}
}
for(i=1;i<m;i++)
{max=x[i];
if(z[i]==0){
for(g=i+1;g<=m;g++)
{
if(y[g]<=max&&z[g]==0){
if(max-y[g]==1&&y[g]%2==1)
z[g]=0;
else{z[g]=1;max=x[g];}
}
}
sum++; } }
if(z[m]==0)
sum++;
printf("%d\n",sum*10);
}
}