首页 > 代码库 > poj 3259 Wormholes

poj 3259 Wormholes


Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30766 Accepted: 11157

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ‘s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,E, T) that describe, respectively: A one way path from S toE that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold


题意:有双向的正边和单项的负边(虫洞的时间是倒流的),问是否能走回去。

思路:用bellman_ford算法判断是否存在负权环。


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

const int INF=1000000009;

struct Node{
    int s,e,t;
}mp[5205];

int d[505];
int n,m,w;

bool bellman_ford(){
    memset(d,INF,sizeof(d));
    d[1]=0;
    for(int i=1;i<n;i++){
        bool flag=true;
        for(int j=1;j<=2*m+w;j++){
            int a=mp[j].s,b=mp[j].e,c=mp[j].t;
            if(d[b]>d[a]+c){
                d[b]=d[a]+c;
                flag=false;
            }
        }
        if(flag) false;
    }
    for(int i=1;i<=2*m+w;i++){
        int a=mp[i].s,b=mp[i].e,c=mp[i].t;
        if(d[b]>d[a]+c)
            return false;
    }
    return true;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(mp,0,sizeof(mp));
        scanf("%d%d%d",&n,&m,&w);
        int k=0;
        for(int i=1;i<=m;i++){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            ++k;
            mp[k].s=x,mp[k].e=y,mp[k].t=z;
            ++k;
            mp[k].e=x,mp[k].s=y,mp[k].t=z;
        }
        for(int i=m+1;i<=m+w;i++){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            ++k;
            mp[k].s=x,mp[k].e=y,mp[k].t=-z;
        }
        if(!bellman_ford()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}