首页 > 代码库 > HUD 2023 求平均数

HUD 2023 求平均数

求平均成绩

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61990????Accepted Submission(s): 14860


Problem Description
假设一个班有n(n<=50)个学生,每人考m(m<=5)门课,求每个学生的平均成绩和每门课的平均成绩,并输出各科成绩均大于等于平均成绩的学生数量。
?

?

Input
输入数据有多个测试实例,每个测试实例的第一行包括两个整数n和m,分别表示学生数和课程数。然后是n行数据,每行包括m个整数(即:考试分数)。
?

?

Output
对于每个测试实例,输出3行数据,第一行包含n个数据,表示n个学生的平均成绩,结果保留两位小数;第二行包含m个数据,表示m门课的平均成绩,结果保留两位小数;第三行是一个整数,表示该班级中各科成绩均大于等于平均成绩的学生数量。
每个测试实例后面跟一个空行。
?

?

Sample Input
2 2 5 10 10 20
?

?

Sample Output
7.50 15.00 7.50 15.00 1
?

?

题解:

#include <iostream>

#include<algorithm>

#include<cmath>

#include<string>

#include<cstdio>

#include<vector>

usingnamespacestd;

float datas[55][5];

?

int main() {

? ? int n,m;

? ? while (scanf("%d %d",&n,&m)!=EOF) {

? ? ? ? vector<bool> item_mask(n);

? ? ? ? for (int i=0; i<n; i++) {

? ? ? ? ? ? float sum=0;

? ? ? ? ? ? for (int j=0; j<m; j++) {

? ? ? ? ? ? ? ? scanf("%f",&datas[i][j]);

? ? ? ? ? ? ? ? sum+=datas[i][j];

? ? ? ? ? ? }

? ? ? ? ? ? if(i!=0) printf(" ");

? ? ? ? ? ? printf("%.2f",sum/m);

? ? ? ? }

? ? ? ? printf("\n");

?? ? ? ?

? ? ? ? for (int k=0;k<item_mask.size(); k++) {//初始化

? ? ? ? ? ? item_mask[k]=true;

? ? ? ? }

? ? ? ? for (int j=0; j<m;j++) {

? ? ? ? ? ? float sum=0;

? ? ? ? ? ? for(int i=0;i<n;i++)

? ? ? ? ? ? ? ? sum+=datas[i][j];

? ? ? ? ? ? if (j!=0) ? printf(" ");

? ? ? ? ? ? sum/=n;

? ? ? ? ? ? for(int i=0;i<n;i++)

? ? ? ? ? ? ? ? if(datas[i][j]<sum)//消除成绩低于平均数的人

? ? ? ? ? ? ? ? ? ? item_mask[i]=false;

? ? ? ? ? ? printf("%.2f",sum);

? ? ? ? }

? ? ? ? printf("\n");

? ? ? ? int count=0;

? ? ? ? for(int i=0;i<n;i++)

? ? ? ? ? ? count+=item_mask[i];

? ? ? ? printf("%d\n\n",count);//每个测试实例后面跟一个空行

? ? }

}