首页 > 代码库 > 统计难题 (字典树)

统计难题 (字典树)

统计难题

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0

对字典树的个人理解:  
                                1,插入操作(建树): 对于每个单词 从根结点(0)开始插入子串,依次建立子节点;
                                                                        把该子节点作为根节点,再往下走。。。。
                                 2,查询操作:      从根节点开始,寻找单词第一个字母位置,找不到就返回。。。。
#include<iostream>
# include<cstring>
#include<cstdio>
using namespace std;
const int maxn=500000;
char wen[20];
struct node{
    int tot;
    int child[26];               //储存子节点,最多为26个;
    node()
    {
        tot=0;
        memset(child,0,sizeof(child));
    }
}tree[maxn];
int sz=0;
void insert(char *s)
{

    int u=0;
    int h=strlen(s);
    for(int i=0;i<h;i++)
    {
        int pos=s[i]-'a';
        if(tree[u].child[pos]==0)
            tree[u].child[pos]=++sz;
        u=tree[u].child[pos];                      //  将子节点作为母结点,往下走;
        tree[u].tot++;
    }
}
int find(char *t)
{

   int u=0;
   int h=strlen(t);
   for(int i=0;i<h;i++)
   {
       int pos=t[i]-'a';
       if(tree[u].child[pos]==0)
        return 0;
       u=tree[u].child[pos];
   }
   return tree[u].tot;
}
int main()
{
    while(gets(wen))
    {
        if(strlen(wen)==0)  break;
        insert(wen);
    }
    while(gets(wen))
    {
          printf("%d\n",find(wen));
    }
    return 0;
}