首页 > 代码库 > poj 1274 The Perfect Stall

poj 1274 The Perfect Stall

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18416 Accepted: 8379

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4



题意:n头奶牛和m个谷仓,每个奶牛有自己喜欢去的谷仓,并且它们只会去自己喜欢的谷仓吃东西,问最多有多少奶牛能够吃到东西。

分析:二分匹配


<span style="font-family:FangSong_GB2312;"><span style="font-size:18px;">#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define M 205

int n,m;
int map[M][M],pre[M],flag[M];

int find(int x)
{
	for(int i=1;i<=m;i++)
	{
		if(map[x][i]==1 && flag[i]==0)
		{
			flag[i]=1;
			if(pre[i]==0 || find(pre[i]))
			{
				pre[i]=x;
				return 1;
			}
		}
		
	}
	return 0;
}

int main ()
{
	int i,j;
	int k,a[M];
	while(cin>>n>>m)   // n头奶牛 m个谷仓
	{
		memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
		for(i=1;i<=n;i++)
		{
			cin>>k;      
			for(j=1;j<=k;j++)
			{
				cin>>a[j];
				map[i][a[j]]=1;   
			}
		}

		int sum=0;
		for(i=1;i<=n;i++)
		{
			memset(flag,0,sizeof(flag));
			if(find(i))
				sum++;
		}
		cout<<sum<<endl;
	}
	return 0;
}</span><span style="color: blue; font-size: 18pt;">
</span></span>