首页 > 代码库 > POJ1734 Sightseeing trip 【Floyd】+【最小环】+【路径记录】

POJ1734 Sightseeing trip 【Floyd】+【最小环】+【路径记录】

Sightseeing trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4830 Accepted: 1857 Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.‘ in case there isn‘t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source

CEOI 1999

Floyd找最小环并输出这个环中的节点。pre[i][j]存储从节点i到节点j第一个第三方节点,初始化为j。

#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
#define maxn 102

int map[maxn][maxn], pre[maxn][maxn];
int dist[maxn][maxn], store[maxn], minCircle;

void getMap(int n, int m)
{
    int i, u, v, d;
    memset(map, 0x3f, sizeof(map));
    for(i = 0; i < m; ++i){
        scanf("%d%d%d", &u, &v, &d);
        if(d < map[u][v])
            map[u][v] = map[v][u] = d;
    }
    memcpy(dist, map, sizeof(map));
}

void solve(int n)
{
    int k, i, j, id, tmp; minCircle = inf;
    for(i = 1; i <= n; ++i)
        for(j = 1; j <= n; ++j) pre[i][j] = j;
    for(k = 1; k <= n; ++k){
        for(i = 1; i <= n; ++i){
            for(j = 1; j <= n; ++j)
                if(i != j && dist[i][j] != inf && map[i][k] != inf && 
                    map[k][j] != inf && dist[i][j] + map[i][k] +
                    map[k][j] < minCircle){
                    minCircle = dist[i][j] + map[i][k] + map[k][j];
                    tmp = i; id = 0;
                    while(tmp != j){
                        store[id++] = tmp;
                        tmp = pre[tmp][j];
                    }
                    store[id++] = j; store[id++] = k;
                }
        }
        for(i = 1; i <= n; ++i)
            for(j = 1; j <= n; ++j)
                if(dist[i][k] != inf && dist[k][j] != inf && 
                    dist[i][k] + dist[k][j] < dist[i][j]){
                    dist[i][j] = dist[i][k] + dist[k][j];
                    pre[i][j] = pre[i][k];
                }
    }
    if(minCircle == inf){
        printf("No solution.\n"); return;
    }
    for(i = 0; i < id; ++i)
        if(i != id - 1) printf("%d ", store[i]);
        else printf("%d\n", store[i]);
}

int main()
{
    int n, m;
    while(scanf("%d%d", &n, &m) == 2){
        getMap(n, m);
        solve(n);
    }
    return 0;
}