首页 > 代码库 > hdu 1162 Eddy's picture

hdu 1162 Eddy's picture

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6838    Accepted Submission(s): 3459


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
3.41
 


题意:给定画上n个点,求最短的线段把所有点连起来,简单的最小生成树

#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 999999
#define M 10005
int n;
int vis[M];
double map[M][M],l[M];

struct node
{
	double x,y;
}p[M];


double dis(int x1,int y1,int x2,int y2)   //计算距离
{
	double k1=x1-x2;
	double k2=y1-y2;
	double k=k1*k1+k2*k2;
	return sqrt(k);
}


int main ()
{
	int i,j,k;
	while(cin>>n)
	{
		for(i=1;i<=n;i++)
			cin>>p[i].x>>p[i].y;
		for(i=1;i<=n;i++)
			for(j=i;j<=n;j++)
				map[i][j]=map[j][i]=dis(p[i].x,p[i].y,p[j].x,p[j].y);
		
		// 最小生成树Prime算法  模板而已

		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
			l[i]=map[1][i];

		vis[1]=1;   // 标记数组
		double sum=0;
		for(i=1;i<n;i++)
		{
			double min=INF;
			for(j=1;j<=n;j++)
			{
				if(vis[j]==0 && l[j]<min)
				{
					min=l[j];
				    k=j;
				}
			}
			sum+=min;
		    vis[k]=1;
			for(j=1;j<=n;j++)  
			{  
				if(!vis[j] && l[j]>map[k][j])  
					l[j]=map[k][j];  
			}
		}

	printf("%.2lf\n",sum);
	}
	return 0;
}