首页 > 代码库 > STL 优先队列

STL 优先队列

原题http://acm.hdu.edu.cn/showproblem.php?pid=1873

看病要排队

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4774    Accepted Submission(s): 1976


Problem Description
看病要排队这个是地球人都知道的常识。
不过经过细心的0068的观察,他发现了医院里排队还是有讲究的。0068所去的医院有三个医生(汗,这么少)同时看病。而看病的人病情有轻重,所以不能根据简单的先来先服务的原则。所以医院对每种病情规定了10种不同的优先级。级别为10的优先权最高,级别为1的优先权最低。医生在看病时,则会在他的队伍里面选择一个优先权最高的人进行诊治。如果遇到两个优先权一样的病人的话,则选择最早来排队的病人。

现在就请你帮助医院模拟这个看病过程。


 

Input
输入数据包含多组测试,请处理到文件结束。
每组数据第一行有一个正整数N(0<N<2000)表示发生事件的数目。
接下来有N行分别表示发生的事件。
一共有两种事件:
1:"IN A B",表示有一个拥有优先级B的病人要求医生A诊治。(0<A<=3,0<B<=10)
2:"OUT A",表示医生A进行了一次诊治,诊治完毕后,病人出院。(0<A<=3)


 

Output
对于每个"OUT A"事件,请在一行里面输出被诊治人的编号ID。如果该事件时无病人需要诊治,则输出"EMPTY"。
诊治人的编号ID的定义为:在一组测试中,"IN A B"事件发生第K次时,进来的病人ID即为K。从1开始编号。


 

Sample Input
7 IN 1 1 IN 1 2 OUT 1 OUT 2 IN 2 1 OUT 2 OUT 1 2 IN 1 1 OUT 1


 

Sample Output
2 EMPTY 3 1 1


 

//开了三个优先队列。每一个代表一个医生。
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <queue>
#include <stack>
#include <deque>
#include <set>
#include <algorithm>
#include <iostream>
#include <map>
#include <math.h>
#include <vector>
using namespace std;

struct node1{
    int sum;
    int id;
    friend bool operator < (node1 a,node1 b){
        if(a.sum == b.sum){
            return a.id > b.id;
        }
        return a.sum < b.sum;
    }
};

struct node2{
    int sum;
    int id;
    friend bool operator < (node2 a,node2 b){
        if(a.sum == b.sum){
            return a.id > b.id;
        }
        return a.sum < b.sum;
    }
};

struct node3{
    int sum;
    int id;
    friend bool operator < (node3 a,node3 b){
        if(a.sum == b.sum){
            return a.id > b.id;
        }
        return a.sum < b.sum;
    }
};

int main(){
    char a[10];
    int n,A,B,C;
    struct node1 p1,p11;
    struct node2 p2,p22;
    struct node3 p3,p33;

    while(~scanf("%d",&n)){
        int count = 1;
        priority_queue<node1>q1;
        priority_queue<node2>q2;
        priority_queue<node3>q3;
        while(n--){
            scanf("%s",a);
            if(a[0] == 'I'){
                scanf("%d%d",&A,&B);
                if(A == 1){
                    p1.id = count;
                    p1.sum = B;
                    q1.push(p1);
                }
                if(A == 2){
                    p2.id = count;
                    p2.sum = B;
                    q2.push(p2);
                }
                if(A == 3){
                    p3.id = count;
                    p3.sum = B;
                    q3.push(p3);
                }
                count++;
            }
            else{
                scanf("%d",&C);
                if(C == 1){
                    if(!q1.empty()){
                        p11 = q1.top();
                        q1.pop();
                        printf("%d\n",p11.id);
                    }
                    else{
                        printf("EMPTY\n");
                    }
                }
                if(C == 2){
                    if(!q2.empty()){
                        p22 = q2.top();
                        q2.pop();
                        printf("%d\n",p22.id);
                    }
                    else{
                        printf("EMPTY\n");
                    }
                }
                if(C == 3){
                    if(!q3.empty()){
                        p33 = q3.top();
                        q3.pop();
                        printf("%d\n",p33.id);
                    }
                    else{
                        printf("EMPTY\n");
                    }
                }
            }
        }
    }

    return 0;
}


 

STL 优先队列