首页 > 代码库 > HDU 1250 Hat's Fibonacci(Java大数相加)+讲解

HDU 1250 Hat's Fibonacci(Java大数相加)+讲解

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.
 
Output
For each case, output the result in a line.
 
Sample Input
100
 
Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


直接用java大数解决即可!


代码如下:

import java.math.BigInteger;  
import java.util.*;  
//import java.io.*; 
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin = new Scanner(System.in);     
        BigInteger num[] = new BigInteger[10017];
        num[1] = new BigInteger("1");
        num[2] = new BigInteger("1");
        num[3] = new BigInteger("1");
        num[4] = new BigInteger("1");
        for(int i = 5; i <= 10000; i++)
        {
        	num[i] = num[i-1].add(num[i-2].add(num[i-3].add(num[i-4])));
        }
        while(cin.hasNext())
        {
        	int n = cin.nextInt();
        	System.out.println(num[n]);
        }
	}

}




刚开始学习Java, 附三篇不错的简单教程链接:

飘过的小牛:(Java类大数练手)

一个人の旅行:(Java大数处理)

From A Start,As An ACMer:(JAVA之BigInteger)



HDU 1250 Hat's Fibonacci(Java大数相加)+讲解