首页 > 代码库 > HDUJ 1250 Hat's Fibonacci

HDUJ 1250 Hat's Fibonacci

Hat‘s Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7338    Accepted Submission(s): 2395


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 


import java.util.Scanner;
import java.math.BigInteger;


public class yhrtr {

	public static void main(String[] args) {
		Scanner cin = new Scanner (System.in);
		BigInteger s[] = new BigInteger[10005];
		s[1] = BigInteger.ONE;
		s[2] = BigInteger.ONE;
		s[3] = BigInteger.ONE;
		s[4] = BigInteger.ONE;
		for(int i=5;i<=10000;i++)
			s[i] = s[i-1].add(s[i-2].add(s[i-3].add(s[i-4])));
	
		while(cin.hasNext())
		{
			int m = cin.nextInt();
			System.out.println(s[m]);
		}
	}
}