首页 > 代码库 > Hat's Fibonacci(杭电1250)

Hat's Fibonacci(杭电1250)

Hat‘s Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7854    Accepted Submission(s): 2551


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646
#include<stdio.h>
#include<string.h>
#define N 10000    //N很关键,N=10000或者20000都可以AC,N取得过小会错。 
int str[N][260];
int main()
{
    memset(str,0,sizeof(str));
    str[1][0]=1;
    str[2][0]=1;
    str[3][0]=1;
    str[4][0]=1;
    int i,j,ans=0,c,n;
    for(i=5;i<N;i++)
    {
        for(j=0,c=0;j<260;j++)
        {
            ans=str[i-1][j]+str[i-2][j]+str[i-3][j]+str[i-4][j]+c;
            c=ans/100000000;
            str[i][j]=ans%100000000;   //每一个数组存8位数字,c来控制是否进位。 
        }
    }
    while(scanf("%d",&n)!=EOF)
    {
        j=259;
        while(!str[n][j])    //将首0清除。 
        j--;
        printf("%d",str[n][j]);
        for(i=j-1;i>=0;i--)
        printf("%08d",str[n][i]);//每8位输出,不足8位自动补0; 
        printf("\n");
    }
    return 0;
}


Hat's Fibonacci(杭电1250)