首页 > 代码库 > PKU 2833 优先队列

PKU 2833 优先队列

原题http://poj.org/problem?id=2833

The Average
Time Limit: 6000MS Memory Limit: 10000K
Total Submissions: 9423 Accepted: 2938
Case Time Limit: 4000MS

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i  n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

//直接做会超内存。所以用优先队列

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <set>
#include <map>
using namespace std;

int main(){
    //priority_queue<int> q1;//从大到小输出
    //priority_queue<int,vector<int>,greater<int>> q2;//从小到大输出
    int max,min,n,i;
    int num;

    while(~scanf("%d%d%d",&max,&min,&n)){
        priority_queue<int>q1;
        priority_queue<int,vector<int>,greater<int> > q2;
        if(max==0 && min==0 && n==0){
            break;
        }
        __int64 sum = 0;
        for(i=1;i<=n;i++){
            scanf("%d",&num);
            sum+=num;
            q1.push(num);
            q2.push(num);
            if(q1.size() > min){
                q1.pop();
            }
            if(q2.size() > max){
                q2.pop();
            }
        }
        while(!q1.empty()){
            int mark = q1.top();
            sum-=mark;
            q1.pop();
        }
        while(!q2.empty()){
            int mark1 = q2.top();
            sum-=mark1;
            q2.pop();
        }
        double ans;
        ans = (sum+0.0)/(n-min-max);
        printf("%.6lf\n",ans);
    }

    return 0;
}


 

PKU 2833 优先队列