首页 > 代码库 > HDU 2035-人见人爱A^B(乘方取模)

HDU 2035-人见人爱A^B(乘方取模)

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22425    Accepted Submission(s): 15667


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

Sample Input
2 3 12 6 6789 10000 0 0
 

Sample Output
8 984 1
第一发 数论,问题描述:求 a^n%m
最简单的思想是用循环分部取余,在n很小的情况下是可以过的,如下
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <vector>
#include <string>
#include <map>
#include <queue>
using namespace std;
int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        if(!a&&!b)break;
        int p=1;
        for(int i=1;i<=b;i++)
            p=p*a%1000;
        cout<<p<<endl;
    }
    return 0;
}

但是当n很大的时候这个循环就要挂掉了,所以要用到数学方法。对指数n进行二分,就会有
a^n%m= a^(n/2)%m n为偶数
a^(n/2)%m * a%m n为奇数
非递归 代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <vector>
#include <string>
#include <map>
#include <queue>
using namespace std;
#define LL long long
LL multimod(LL a,LL n,LL m)
{
    LL ans=1,tem=a;
    while(n)
    {
        if(n&1)//判断是否为奇数
            ans=ans*tem%m;
        tem=tem*tem%m;
        n/=2;
    }
    return ans;
}
int main()
{
    LL a,b;
    while(cin>>a>>b)
    {
        if(!a&&!b)break;
        cout<<multimod(a,b,1000)<<endl;
    }
    return 0;
}


HDU 2035-人见人爱A^B(乘方取模)