首页 > 代码库 > HDOJ 5015 233 Matrix

HDOJ 5015 233 Matrix


构造矩阵+快速幂


233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 344    Accepted Submission(s): 231


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell me an,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).
 

Output
For each case, output an,m mod 10000007.
 

Sample Input
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
234 2799 72937
Hint
 

Source
2014 ACM/ICPC Asia Regional Xi‘an Online
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

const LL MOD=10000007LL;

int n,m;
LL a[20];

struct Matrix
{
	int x,y;
	LL matrix[12][12];
	Matrix()
	{
		x=y=0;
		memset(matrix,0,sizeof(matrix));
	}
};

void init(Matrix& m)
{
	m.x=m.y=n+2;
	for(int i=0;i<m.x-2;i++)
		for(int j=i;j<m.y-1;j++)
			m.matrix[i][j]=1;
	m.matrix[m.x-2][m.y-2]=10;
	m.matrix[m.x-1][m.y-1]=m.matrix[m.x-2][m.y-1]=1;
}

Matrix CHENGFA(Matrix& a,Matrix& b)
{
	int n=a.x;
	Matrix ret;
	ret.x=ret.y=n;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			LL temp=0;
			for(int k=0;k<n;k++)
			{
				temp=(temp+(a.matrix[i][k]*b.matrix[k][j])%MOD)%MOD;
			}
			ret.matrix[i][j]=temp%MOD;
		}
	}
	return ret;
}

Matrix MatrixQuickPow(Matrix m,int k)
{
	Matrix e;
	int n=m.x;	
	e.x=e.y=n;
	for(int i=0;i<n;i++) e.matrix[i][i]=1;
	while(k)	
	{
		if(k%2)
			e=CHENGFA(e,m);
		m=CHENGFA(m,m);
		k/=2;
	}
	return e;
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=n-1;i>=0;i--)
			scanf("%lld",a+i);
		a[n]=233; a[n+1]=3;
		Matrix M,ED;
		init(M);
		ED=MatrixQuickPow(M,m-1);
		LL ans=0;
		for(int i=0;i<n+1;i++)
		{
			LL temp=0;
			for(int j=0;j<n+2;j++)
			{
				temp=(temp+(ED.matrix[i][j]*a[j])%MOD)%MOD;	
			}
			ans=(ans+temp)%MOD;
		}
		printf("%I64d\n",ans);
	}
	return 0;
}




HDOJ 5015 233 Matrix