首页 > 代码库 > hdu 5014 Number Sequence(意淫题)

hdu 5014 Number Sequence(意淫题)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 545    Accepted Submission(s): 258
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● ai ∈ [0,n] 
● ai ≠ aj( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0 ≤ i ≤ n - 1). Don’t ouput any spaces after bn.
 

Sample Input
4 2 0 1 4 3
 

Sample Output
20 1 0 2 3 4
 

Source
2014 ACM/ICPC Asia Regional Xi‘an Online
 


题解及题解:


       瞎搞就搞出来了,最后的结果是n*(n+1),手算一下前5个就能看出来。剩下的输出从大开始向下遍历,输出2^(len)-1-i就可以了,边计算边标记(len为当前数的2进制表示形式的位数)。


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int len(int n)
{
    int ans=0;
    while(n)
    {
        n>>=1;
        ans++;
    }
    return ans;
}

int s[100010];
int t[100010];
int main()
{
    int n,le,v;
    __int64 d;
    while(scanf("%d",&n)!=EOF)
    {
        memset(s,-1,sizeof(s[0])*(n+5));
        for(int i=0;i<=n;i++)
        {
            scanf("%d",&t[i]);
        }

        for(int i=n;i>=0;i--)
        if(s[i]<0)
        {
            le=len(i);
            v=1<<le;
            v--;
            s[i]=v-i;
            s[v-i]=i;
        }
        __int64 m=(__int64)n;
        d=m*(m+1);
        printf("%I64d\n",d);
        for(int i=0;i<n;i++)
        {
            printf("%d ",s[t[i]]);
        }
        printf("%d\n",s[t[n]]);
    }
    return 0;
}






hdu 5014 Number Sequence(意淫题)