首页 > 代码库 > HDU 1005 Number Sequence

HDU 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 154923    Accepted Submission(s): 37854


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 31 2 100 0 0
 

 

Sample Output
25
 

 

Author
CHEN, Shunbao
 

 

Source
ZJCPC2004
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1003 1009 
 
 
/*-----------------------f[i-1]%7与f[i-2]%7都有0,1,2,3,4,5,6七种可能的取值,所以f[i]的取值最大有49种,也就是在49次计算
内,至少出现一次循环,当f[i-1]与f[i]等于1(f[1],f[2]等于1)的时候,即为循环出现,周期cycle = i - 2;----------------------*/
 
 
 

#include<iostream>
using namespace std;

int main()
{
int cycle,i; //周期
int f[50];
int a,b,n;
f[1] = f[2] = 1;
while(cin>>a>>b>>n,a+b+n)
{
for( i = 3;i <= 49;i++)
{
f[i] = (a*f[i-1] + b*f[i-2])%7;
if(f[i] == f[i-1] && f[i] == 1) break;
}
cycle = i - 2;
n = n%cycle;
if(n==0)
cout<<f[cycle]<<endl;
else
cout<<f[n]<<endl;
}
return 0;
}

 

HDU 1005 Number Sequence