首页 > 代码库 > POJ - 3261 Milk Patterns (后缀数组求可重叠的 k 次最长重复子串)
POJ - 3261 Milk Patterns (后缀数组求可重叠的 k 次最长重复子串)
Description
Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can‘t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.
To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.
Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.
Input
Lines 2.. N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.
Output
Sample Input
8 2 1 2 3 2 3 2 3 1
Sample Output
4
题意:给定一个字符串,求至少出现k 次的最长重复子串,这k个子串可以重叠。
思路:和上一题POJ - 1743 Musical Theme一样也是二分答案,然后将后缀分成若干组,不同的是,这里要判断的是有没有一个组的后缀heigh[]不小于mid。如果有,那么再有连续的k个存在的话,就满足条件。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 20010;
int sa[maxn]; //SA数组,表示将S的n个后缀从小到大排序后把排好序的
//的后缀的开头位置顺次放入SA中
int t1[maxn], t2[maxn], c[maxn];
int rank[maxn], height[maxn];
int s[maxn];
void build_sa(int s[], int n, int m) {
int i, j, p, *x = t1, *y = t2;
for (i = 0; i < m; i++) c[i] = 0;
for (i = 0; i < n; i++) c[x[i] = s[i]]++;
for (i = 1; i < m; i++) c[i] += c[i-1];
for (i = n-1; i >= 0; i--) sa[--c[x[i]]] = i;
for (j = 1; j <= n; j <<= 1) {
p = 0;
for (i = n-j; i < n; i++) y[p++] = i;
for (i = 0; i < n; i++)
if (sa[i] >= j)
y[p++] = sa[i] - j;
for (i = 0; i < m; i++) c[i] = 0;
for (i = 0; i < n; i++) c[x[y[i]]]++;
for (i = 1; i < m; i++) c[i] += c[i-1];
for (i = n-1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
swap(x, y);
p = 1, x[sa[0]] = 0;
for (i = 1; i < n; i++)
x[sa[i]] = y[sa[i-1]] == y[sa[i]] && y[sa[i-1]+j] == y[sa[i]+j] ? p-1 : p++;
if (p >= n) break;
m = p;
}
}
void getHeight(int s[],int n) {
int i, j, k = 0;
for (i = 0; i <= n; i++)
rank[sa[i]] = i;
for (i = 0; i < n; i++) {
if (k) k--;
j = sa[rank[i]-1];
while (s[i+k] == s[j+k]) k++;
height[rank[i]]=k;
}
}
int check(int n, int k, int mid) {
int num = 1;
for (int i = 2; i <= n; i++) {
if (height[i] >= mid) {
num++;
if (num >= k) return 1;
}
else num = 1;
}
return 0;
}
int main() {
int n, k;
while (scanf("%d%d", &n, &k) != EOF) {
int Max = 0;
for (int i = 0; i < n; i++) {
scanf("%d", &s[i]);
Max = max(Max, s[i]);
}
s[n] = 0; //notice
build_sa(s, n+1, Max+1);
getHeight(s, n);
int l = 0, r = n;
int ans = 0;
while (l <= r) {
int mid = l + r >> 1;
if (check(n, k, mid)) {
ans = mid;
l = mid + 1;
}
else r = mid - 1;
}
printf("%d\n", ans);
}
return 0;
}
POJ - 3261 Milk Patterns (后缀数组求可重叠的 k 次最长重复子串)